当前位置: 首页 > >

Windows下安装Python机器学*相关的sklearn(scikit-learn)模块

发布时间:





参考官方网页:


http://scikit-learn.org/dev/developers/advanced_installation.html#install-bleeding-edge




截图如下:






在cmd窗口下输入:


pip install -U scikit-learn ? ?(安装或更新都是输入这个命令)






因为我先安装了Anaconda,所以默*沧傲0.17版本的scikit-learn,但在ipython交互模式下输入:


from sklearn.model_selection import KFold 时出错,提示“No module named model_selection”。


如下图:








查了资料发现原来只有在scikit-learn 0.18以上的版本才有model_selection模块,如果是0.18以下的版本要用到KFold,StratifiedKFold等class就必须从sklearn.cross_validation导入:




from sklearn.cross_validation import KFold




这个版本的KFold等的参数跟0.18的不太一样,详情见官网文档。





友情链接: